Attempted to perform an unauthorized operation

Dec 1, 2010 at 12:36 PM


The tool looks very promising, but I'm getting an exception when I try to connect to the site:

"Attempted to perform an unauthorized operation"

I get the same exception, when trying to access the Search.asmx web service from a console application.

My site is using claims based authentication. Windows authentication and forms authentication are enabled.


What is the trick to get the web service access to work. I have been experimenting with the Authentication.asmx and I'm able to authenticate users with username and password (no domain), but I still get the same exception when accessing the Search.asmx web service.


Hope you have some pointers..



Jan 24, 2012 at 6:22 PM

I had the same problem What I had to do was disable anonymous access to the SharePoint site in IIS.

Nov 7, 2012 at 3:58 PM

I have the same problem but I can't disable anonymous access because I want to query a public website. Any pointers, anyone?

Jan 3, 2013 at 1:19 PM

Not exactly a solution, but if you disable the Anonymous access only when you login first using the Query Tool, you can then turn it back on and successfully use the tool. Worked for me as a workaround.